カメラアプリで[…is deprecated…]エラー

カメラアプリを作成してiPhone実機で動作テストをしてみたら
こんなエラーが表示されました。

WARNING: -[ 
setAutomaticallyAdjustsMirroring:] is deprecated.  
Please use AVCaptureConnection's -setAutomaticallyAdjustsVideoMirroring:

ネットで調べても解決方法がよくわからなかったですが
英語の意味を調べてみると「setAutomaticallyAdjustsMirroring」は
廃止されたので「setAutomaticallyAdjustsVideoMirroring」を
使ってほしいということらしいです。

どうやらiOS6では「setAutomaticallyAdjustsMirroring」ではなく
「setAutomaticallyAdjustsVideoMirroring」を使えって意味みたい。

でも、作成したソースを「setAutomaticallyAdjustsMirroring」を
検索しても見つからない。
似たようなやつで「automaticallyAdjustsMirroring」は一カ所だけ使ってた。

なので、「automaticallyAdjustsMirroring」の部分を
単純に「automaticallyAdjustsVideoMirroring」と書き換えてみたけど
使い方が違うようでエラーになる。

だけど、「setAutomaticallyAdjustsVideoMirroring」が
iOS6から使われるコードだとしたらiOS5では使えないので
iOS6の場合とそれ以外で処理を書き分けないといかんのでは?

なんだか面倒になってきた。
このエラーは無視しても大丈夫かもしれないので
解決策がわかるまではそのままにしておこう。

コメントは受け付けていません。

このページの先頭へ